Имеется таблица excel, в 1-м столбце-10 000 ячеек английского текста. Во второй - русский перевод соответствующей ячейки. Некоторые ряды (не все, а, например, с 200 по 300 и далее вразброс) имеют в 3-м столбце цифру 2. Необходимо посчитать количество введенных русских символов (то есть переведенный текст) во 2-м столбце, но только в тех рядах, которые отмечены цифрой "2". То есть, нужно скопировать соответствующие ячейки в документ Word и далее уже подвести статистику знаков. каким образом организовать данные действия? Заранее благодарен за своевременный ответ, т.к. вопрос срочный.

задан 7 Май '12 22:38

изменен 18 Май '12 1:05

Expert's gravatar image


51625

@Alkotrasher, Согласно правилам форума, вопросы не должны сводиться к решению либо завершению учебных заданий за учащихся. Пожалуйста, уточните, что вы сделали сами и что не получилось.

(18 Май '12 1:06) Expert

Если предположить, что в столбце все русские символы, то можно так (исключая пробелы): =СУММ(ДЛСТР(ПОДСТАВИТЬ(ЕСЛИ(C1:C10000=2;B1:B10000;"");" ";))) формула массива, вводится одновременным нажатием Ctrl+Shift+Enter.

отвечен 13 Май '12 8:58

изменен 18 Май '12 1:06

Expert's gravatar image


51625

  1. Не обязательно копировать в word для подсчета знаков. Есть вариант сохранить в txt прямо из excel либо воспользоваться помощью програмки: http://www.practiline.com/
  2. Для того, чтобы выбрать по нужному фильтру, в вашем случае по значению в третьем столбце равному цифре "2" - использовать формулу или на этом же листе или на другом листе такого плана: =ЕСЛИ(ИЛИ(R4176="";R4176=0);"";R4176) - если ячейка будет пустая или будет стоять цифирка 0, то значение переноситься не будет. там уже на практике немного пошевелите извилинами и все получится :)

отвечен 12 Май '12 12:50

изменен 18 Май '12 1:06

Expert's gravatar image


51625

Здравствуйте

БитКод - это совместно редактируемый форум вопросов и ответов для продвинутых пользователей компьютерной техники.

Присоединяйтесь!

отмечен:

×48
×2

задан
7 Май '12 22:38

показан
1114 раз

обновлен
18 Май '12 1:06

Отслеживать вопрос

по почте:

Зарегистрировавшись, вы сможете подписаться на любые обновления

по RSS:

Ответы

Ответы и Комментарии

Дизайн сайта/логотип © «Сеть Знаний». Контент распространяется под лицензией cc by-sa 3.0 с обязательным указанием авторства.
Рейтинг@Mail.ru